메일보내기시 사용자 인증

Mozilla Thunderbird 사용에 대한 일반적인 질문과 답을 해 주는 게시판입니다. 질문을 하기 전에 FAQ를 읽어 보시는게 도움이 될 것입니다.
댓글 게시
보아스
게시물: 9
참여됨: 2004 05 20 13:48 47
연락:

메일보내기시 사용자 인증

게시물 작성자 보아스 » 2005 01 07 17:51 25

오늘 메일서버 제공업체에서 갑자기 Qmail로 서버를 교체하고 통보를 해왔습니다.

불편을 감수하고 모든 셋팅을 변경하였는데 한가지 문제가 해결되지 않았습니다.

메일서버는 Qmail 이랍니다. 버번은 확실하지 않습니다.
제가 사용하는 메일 클라이언트는 넷스케이프 7.1 입니다.
선더버드 1.0으로도 테스트 하였습니다.
아마도 같은 모질라계열이 아닌가 싶습니다.

메일서버주소는 mail.twrk.or.kr이고
사용자 는 AAA@twrk.or.kr
이렇게 하였습니다.

pop3를 통해 메일을 불러오는 것은 문제가 없는데
smtp를 통해 메일을 발송할때는 사용자 인증을 넘어가질 못합니다.

업체쪽에서는 OE를 표준으로 삼기때문에 OE에서 문제가 없기때문에 조치해 줄 수 없다고 합니다.
그러나, 문제가 무엇인지 확인되면 서버 셋팅은 해 줄 수 있다는 것입니다.
즉 사용자가 문제 해결책을 찾아라 이것입니다.

문외한으로 배우는 중이라 어디에서 무엇을 참고해야 할지 난감합니다.
관련문건이 있는 곳이나, 해결방법을 아시는 분 조언을 부탁드립니다.

빛알갱이
해커
해커
게시물: 1146
참여됨: 2004 01 15 20:06 36

게시물 작성자 빛알갱이 » 2005 01 07 18:47 41

메일 써버에 접속해서 EHLO를 준 결과 나온 Auth 관련 확장 SMTP 목록입니다.

250-STARTTLS
250-AUTH LOGIN CRAM-MD5 PLAIN
250-AUTH=LOGIN CRAM-MD5 PLAIN

인증 설정을 어떻게 하셨습니까? TLS를 체크하셔야 할 것 같군요. 'Outgoing server(SMTP)' 설정 부분에서 체크해 보고 다시 시도해 보십시오.

보아스
게시물: 9
참여됨: 2004 05 20 13:48 47
연락:

테스트 결과 입니다.

게시물 작성자 보아스 » 2005 01 08 11:45 43

말씀해주신 부분 테스트 해봤습니다.

우선 아무것도 선택않기경우
암호창이 나오고 암호입력하면 재입력창이 나옵니다. 계속 반복됩니다.
취소하면 발송실패창이 나옵니다.

필요할 경우 TLS 선택의 경우
위의 경우와 같습니다.

TLS 선택의 경우
암호 입력창이 나오지 않고 다음의 에러 메시지 창이 나옵니다.
[메일 보내는 중 에러발생 메일서버 mail.twtk.or.kr에 접속할 수 없습니다. 메일서버가 다운 되었거나 제대로 설정되지 않았습니다. 설정을 확인하시고 다시 시도해 보세요.

korea.com의 smtp는 문제없이 사용하고 있습니다.

빛알갱이
해커
해커
게시물: 1146
참여됨: 2004 01 15 20:06 36

게시물 작성자 빛알갱이 » 2005 01 08 13:33 34

웹에서 TLS, SMTP AUTH, qmail과 모질라 메일 및 TB의 궁합이 어떤지 찾아 보았는데, 안 된다는 말을 못 찾았습니다. 다 잘 된다고 나오거든요. 혹시, 'SMTP over SSL'을 쓰나 해서 465번 포트로 접속해 보았지만, 접속할 수 없더군요.

qmail에 그런 기능을 구현한 패치가 좀 여러 개 있어서 어떤 것을 적용해서 컴파일했느냐에 따라 좀 달리질 가능성이 있기는 합니다.

MS Outlook (Express)에서 설정을 어떻게 했을 때 잘 되는지요? 그 설정에 대응하는 TB 설정을 찾아 해 보아야 할 것 같은데요.

보아스
게시물: 9
참여됨: 2004 05 20 13:48 47
연락:

기본설정입니다.

게시물 작성자 보아스 » 2005 01 08 18:39 40

아웃룩익스프레스에서의 설정은 기본입니다.

일반
메일계정 mail.twrk.or.kr
이름 twrk
조직
전자메일주소 twrk@twrk.or.kr
회신주소

서버
받는메일서버유형 POP3
받는메일 mail.twrk.or.kr
보내는메일 mail.twrk.or.kr

받는메일서버
계정이름 twrk@twrk.or.kr

보안 암호 인증을 사용하여 로그온 해제

보내는 메일서버 인증필요 체크 -> 설정
로그온 정보
계정이름 twrk@twrk.or.kr
보안암호인증을 사용하여 로그온 해제


고급
보내는메일 포트 25

나버지 전부 해제

이렇게 되어 있습니다.

너무나 자연스럽게 진행되는데요....

문제해결을 위해
가능하다면 제가 임시계정을 하나 만들어 드릴 수도 있습니다.

빛알갱이
해커
해커
게시물: 1146
참여됨: 2004 01 15 20:06 36

게시물 작성자 빛알갱이 » 2005 01 10 23:26 45

https://bugzilla.mozilla.org/show_bug.cgi?id=204371
https://bugzilla.mozilla.org/show_bug.cgi?id=73693

위에서 언급한 버그들 중 하나인 것 같군요. 204371과 같은 케이스가 아닌 것 같기는 한데 (login, plain도 cram-md5와 더불어 지원한다고 써버가 주장하므로), 제일 가까운 것이 그 버그입니다.

계정을 하나 임시로 만들어 주셔서 제가 TB와 SMTP server 사이의 통신 log를 보는 것이 제일 확실한 방법이 될 것 같습니다. 제게 메일로 임시 계정과 패스워드를 보내 주시면 제가 해 보겠습니다.

보아스
게시물: 9
참여됨: 2004 05 20 13:48 47
연락:

빛알갱이님 메일 주소가?

게시물 작성자 보아스 » 2005 01 11 15:38 53

임시 계정을 생성하여 알려드리고 싶은데 빛 알갱이님 메일 주소를 알 길이 없습니다.

저의 boazs@korea.com으로 메일 주시면 감사하겠습니다.

kscha

저도 이와같은 일이 벌어집니다.

게시물 작성자 kscha » 2005 01 17 20:07 59

저도 이와같은 현상이 벌어지는데 부탁드립니다.

빛알갱이
해커
해커
게시물: 1146
참여됨: 2004 01 15 20:06 36

Re: 빛알갱이님 메일 주소가?

게시물 작성자 빛알갱이 » 2005 01 17 20:45 32

보아스 씀:임시 계정을 생성하여 알려드리고 싶은데 빛 알갱이님 메일 주소를 알 길이 없습니다.

저의 boazs@korea.com으로 메일 주시면 감사하겠습니다.
지난 주 금요일에 이미 메일을 받았고, 메일 답장도 드렸는데요 :-) 일요일 오후 7:30부터 오늘 오전까지는 제 ISP에 문제가 있어서 메일을 받지 못 했고요.

어쨌든, 문제는 SMTP 써버의 경우 '사용자 이름과 암호 사용하기'를 체크하지 않으면 간단하게 해결됩니다. 이것이 의도한 바인지 실수인지 모르겠지만, qmail 설정에서 SMTP AUTH를 하지 않고 아무나 쓸 수 있도록 - SMTP after POP3를 해 놓은 것 같지도 않습니다. - 해 놓았습니다. TLS를 위한 cert 파일도 설치해 놓지 않았더군요. (qmail은 친절하게 그런 것까지 응답에서 알려 주네요 :-))

그리고, 여기서 메일 보내시려면 '개인 정보' 단추를 누르면 나오는 메일 보내기 기능을 이용하시면 됩니다. (그냥 '메시지 보내기'는 저도 안 됩니다.)

Knoll

저와 비슷한 경우시군요.

게시물 작성자 Knoll » 2005 01 18 00:23 19

저는 mail.co.kr 을 쓰고있는데 POP3로 불러오는것은 아무런 문제없이 잘되지만
마찬가지로 SMTP로 보내는 경우에는

[메시지 보내기 실패. SMTP서버 mail.co.kr 연결에 에러가 발생하여 메세지를 보낼 수 없습니다. 서버가 없거나 연결이 거부되었습니다. SMTP서버 설정을 확인하시고 재시도 하거나 네트웍관리자에게 문의하십시요.]

라는 에러창이 뜹니다. 물론 이름과 암호사용부분에는 체크를 한 상테입니다.

SMTP서버 설정을 kornet.net 으로 해놓고 쓰면 아무문제가 없는걸로 보아 mail.co.kr쪽에서 먼가가 잘못되어있는것 같다는 추측되어지는데, 머... 기다려 보는수 밖에 없을거 같습니다.

혹시 이곳에 mail.co.kr사용하시면서 저와 같은 경우를 극복하신분 계신가요?

빛알갱이
해커
해커
게시물: 1146
참여됨: 2004 01 15 20:06 36

Re: 저와 비슷한 경우시군요.

게시물 작성자 빛알갱이 » 2005 01 18 12:00 11

Knoll 씀: 라는 에러창이 뜹니다. 물론 이름과 암호사용부분에는 체크를 한 상테입니다.
이름과 암호 사용을 체크하지 말고 시도해 보세요. SMTP 인증을 하지 않는 서버인데, 인증을 하려고 해서 생기는 문제일 수도 있습니다. (보아즈님의 경우가 그런 경우였습니다.) 아니면, TLS와 SSL 설정 조합을 여러 가지로 달리해서 시도해 보시거나요. 그래도, 문제를 풀 수 없으면 환경 변수 NSPR_LOG_MODULES를 'SMTP:5'로 설정하고서 TB를 명령창에서 실행시켜서 그 출력 결과를 여기에 올려 주세요.

보아스
게시물: 9
참여됨: 2004 05 20 13:48 47
연락:

빛알갱이님 감사합니다.

게시물 작성자 보아스 » 2005 01 18 13:08 37

저도확인했습니다.
이곳 글 읽자마자 테스트 해봤습니다.

SMTP 설정에서 이름과 암호사용을 해제하면 됩니다.
아주 잘 됩니다.

헉! 이렇게 허무할 수가 이것때문에 마음 고생한 것 생각하면...

빛알갱이님의 정확한 분석으로 잘 해결되었습니다.

다른 분들도 한 번 해보세요.

=======

그건 그렇고 빛알갱이님, korea.com에 메일이 제대로 도착하지 않는 것이 수신쪽 문제인지 님의 발신쪽 문제인지 아니면 본문이나 제목의 스팸성 문구 때문인지 모르겠습니다. 이곳에도 글 남겨 주셔서 감사드립니다.

그리고 임시계정은 삭제하였습니다.

physicist

저도 비슷한 경우 입니다.

게시물 작성자 physicist » 2005 11 02 10:16 26

위에서 여러분들이 이야기 한것과 마찬가지입니다.

일단 아웃룩 익스프래스에서 설정하면 아무런 문제가 없습니다.

같은 설정을 썬더버드에게 하면 받기 메일은 잘 작동하나, 보내기 메일이 작동하지 않습니다.

사용자 이름 및 암호 사용을 해제하면, 같은 도메인에 있는 사람에게만 보내기 메일이 작동하며, 외부로의 발송은 되지않습니다. (한메일, 쥐메일, 네이버메일 등등)

사용자 이름 및 암호 사용을 체크하면, 윗분들과 마찮가지로 메일서버 설정을 다시 하라는 메세지가 날라옵니다.

여기서 이상한 것은, 옵션의 패스워드 관리자에 들어가보면...

받기메일 관련 해서는 사용자 이름과 암호가 나타납니다만,

보내기메일 관련해서는 사용자 이름이 < not specified >으로 나옵니다.

그래서 위의 상황이 되는 것이 아닌가 싶습니다만...

다른 분들은 어떤가 싶네요..

저는 1.0.7 영문판과 1.5 beta2 영문판을 사용합니다.


댓글 게시

누군가 접속

유저들이 이 포럼을 탐색중: 가입된 유저 없음 그리고 0 손님들