이미지가... 완전히 나타나는것 같지가 않아요

Mozilla Firefox 사용에 대한 일반적인 질문과 답을 해 주는 게시판입니다. 질문을 하기 전에 FAQ를 읽어 보시는게 도움이 될 것입니다.
댓글 게시
Mirai

이미지가... 완전히 나타나는것 같지가 않아요

게시물 작성자 Mirai » 2005 03 13 18:28 01

같은 홈페이지를 파폭하고 IE하고 열어봤을 때에

IE에서는 보이는 이미지(홈페이지 최상단의)가 파폭에선 보이지 않는군요;


여기 사이트만 해도 전체적으로 하얀게 희한합니다;
무슨 이미지를 제한하는건지...
그럼 몇가지 보이는 이미지는 뭔지...


옵션을 뒤져봐도 잘 모르겠군요;
이거 튜토리얼같은건 없을까요;

어느 이글루 블로그에 '불여우는 믿을수 있습니다' 라는 배너를 보고 와보았는데...

유저 아바타
xeon
서포터즈
서포터즈
게시물: 94
참여됨: 2004 03 05 16:13 00

게시물 작성자 xeon » 2005 03 13 20:00 13

해당 사이트의 주소를 남겨주시면 답변드리기 수월할것 같습니다.

소프트원트

게시물 작성자 소프트원트 » 2005 03 13 20:03 34

일단 해당 사이트에서 이미지의 width/height 값이 주어져있는 지 확인해보세요. 대부분의 개발자들이 이지웍편집툴을 사용하여 웹페이지를 만드는 경우가 많고, 과거에 만들어진 편집툴은 W3C의 표준을 준수하지않는 경우가 많습니다.

무엇보다 어떤 사이트가 문제가 되는 지 올려서 다른 사용자들의 의견을 물어보는 게 좋을 듯싶내요.

그냥 문제가 있다고 지적하면 도움이 되지않는 경우가 많습니다.

그리고 모질라에서는 사이트내 이미지를 차단하는 기능이 있습니다.

이미지에 마우스 오른쪽 버튼을 클릭하면,, [사이트명]...에서 차단.. 이 기능을 이용하신 적은 없는지요.

그리고 환경설정에 보시면, [웹주요기능]에 그림읽기가 있습니다.

이 옵션이 해제되어 있는 지 확인해보시기 바랍니다.

전체적으로 문제가 해결되지않는다면, 일단 프로그램과 프로필 폴더 모두를 삭제하시고 다시 설치해보시기 바랍니다.

유저 아바타
xeon
서포터즈
서포터즈
게시물: 94
참여됨: 2004 03 05 16:13 00

제가 잘못 이해한것 같습니다...

게시물 작성자 xeon » 2005 03 13 20:26 13

xeon 씀:해당 사이트의 주소를 남겨주시면 답변드리기 수월할것 같습니다.
죄송합니다.
본문의 내용을 잘못 파악한것 같습니다.
특정사이트에서 일어나는 일이라고 이해를 해버려서 실수를 했네요...

Options(환경설정)의 Web Features(웹 주요기능)에서 Load Images(그림 읽기)에 체크가 되어있는지 확인 하시고, for the originating web site only(한국어판에 어찌 의역되있는지 기억이... 아무튼 'Load Images'의 하위 메뉴)에 체크가 해제 되어있는지 확인해 보세요
Load Images에는 필히 체크가 되어있어야 페이지를 이용하시는데 지장이 없습니다.

유저 아바타
mirai
서포터즈
서포터즈
게시물: 87
참여됨: 2005 03 13 21:45 04
위치: 집안[...]
연락:

Re: 제가 잘못 이해한것 같습니다...

게시물 작성자 mirai » 2005 03 13 23:17 01

xeon 씀:
xeon 씀:해당 사이트의 주소를 남겨주시면 답변드리기 수월할것 같습니다.
죄송합니다.
본문의 내용을 잘못 파악한것 같습니다.
특정사이트에서 일어나는 일이라고 이해를 해버려서 실수를 했네요...

Options(환경설정)의 Web Features(웹 주요기능)에서 Load Images(그림 읽기)에 체크가 되어있는지 확인 하시고, for the originating web site only(한국어판에 어찌 의역되있는지 기억이... 아무튼 'Load Images'의 하위 메뉴)에 체크가 해제 되어있는지 확인해 보세요
Load Images에는 필히 체크가 되어있어야 페이지를 이용하시는데 지장이 없습니다.


그부분은 체크되어있고요 하위부분 체크 꺼놨어요.
'그림 읽기' 하고 '원래 웹사이트에만' 으로 해석되었던데...
그림읽기 체크 꺼놓으니 그림이 넷스케이프에서 이미지를 못 읽었을때 모습같이 나오고... '원래 웹사이트에만'은 전혀 무관한것 같네요;

그냥 IE 쓰는게 나을라나요?;

박민권
해커
해커
게시물: 724
참여됨: 2005 01 31 22:33 55
위치: 대한민국
연락:

음 ㅡㅡa

게시물 작성자 박민권 » 2005 03 13 23:57 24

이 사이트도 이미지가 안뜨나요?
원래 이 사이트가 좀 하얗습니다.
익스와 비교했을때 어떤 부분이 안뜨는지 가르쳐 주세요.
아니면 다른 사이트와 비교했을때 어떤 부분이 안뜨는지 사이트의 주소를
같이 적어주시면 문제해결에 도움이 될 것 같습니다.

대부분 표준을 잘 지키지 못해서 이미지가 안뜨거나 디자인이 깨지는 것이 다반사구요.
익스가 워낙 시스템을 엉망으로 만들어서 다른 프로그램의 실행에도 악영향을
미치고 있습니다. 악성코드의 근본이 익스니까요.

저는 불여우 쓰면서 악성코드에 걸린적이 없습니다.
웹개발자 입장에서 볼때 익스를 계속 쓰실경우 시스템을 점점 망칠 가능성이 높아집니다.
다시한번 사이트의 주소와 정확한 문제를 적어주시면 감사하겠습니다.

유저 아바타
mirai
서포터즈
서포터즈
게시물: 87
참여됨: 2005 03 13 21:45 04
위치: 집안[...]
연락:

Re: 음 ㅡㅡa

게시물 작성자 mirai » 2005 03 14 12:59 48

박민권 씀:이 사이트도 이미지가 안뜨나요?
원래 이 사이트가 좀 하얗습니다.
익스와 비교했을때 어떤 부분이 안뜨는지 가르쳐 주세요.
아니면 다른 사이트와 비교했을때 어떤 부분이 안뜨는지 사이트의 주소를
같이 적어주시면 문제해결에 도움이 될 것 같습니다.

대부분 표준을 잘 지키지 못해서 이미지가 안뜨거나 디자인이 깨지는 것이 다반사구요.
익스가 워낙 시스템을 엉망으로 만들어서 다른 프로그램의 실행에도 악영향을
미치고 있습니다. 악성코드의 근본이 익스니까요.

저는 불여우 쓰면서 악성코드에 걸린적이 없습니다.
웹개발자 입장에서 볼때 익스를 계속 쓰실경우 시스템을 점점 망칠 가능성이 높아집니다.
다시한번 사이트의 주소와 정확한 문제를 적어주시면 감사하겠습니다.


음..
제 개인블로그를 파이어폭스로 읽은 모습을 제 블로그에 올려놨었거든요.
http://mirai.egloos.com 이 제 블로그 주소고요,
http://pds.egloos.com/pds/1/200503/13/0 ... 242823.jpg
가 그 이미지입니다


이곳 포럼 페이지에서도 몇몇 색깔이 나타나지 않거나
파이어폭스 맨처음 페이지에도 상자 가운데가 잘려나간 것처럼 보여요.
(입력창은 보이는데 그 입력창을 감싸는 상자가 중간이 잘린것처럼 보입니다.)

적어도 이 문제는 해결이 되어야 IE를 대체하거나 할텐데 말이지요;

유저 아바타
XviD
해커
해커
게시물: 664
참여됨: 2004 11 14 14:55 45
위치: 사막의 오아시스
연락:

Re: 음 ㅡㅡa

게시물 작성자 XviD » 2005 03 14 13:27 57

mirai 씀: 제 개인블로그를 파이어폭스로 읽은 모습을 제 블로그에 올려놨었거든요.
http://mirai.egloos.com 이 제 블로그 주소고요,
http://pds.egloos.com/pds/1/200503/13/0 ... 242823.jpg
가 그 이미지입니다.
그것 참 신기하군요.
그림 표시에는 아무런 문제가 없습니다.
블로그 전체 배경도 마찬가지고요.
이곳 포럼도 문제 없고요.

아무래도 파이어폭스를 삭제한 후 프로필 폴더까지 수동으로 삭제하고 다시 설치해보셔야할 것 같습니다.
그 전에 혹시 모르니 mirai님의 컴퓨터에 바이러스, 웜, 트로이 목마, 애드웨어, 스파이웨어 등의 악성 소프트웨어가 있는지 백신과 스파이웨어 제거 소프트웨어로 검사부터 먼저 해보는 것도 좋을 것 같습니다.
그리고 현재 mirai님이 사용하고 계신 테마 관련 소프트웨어(스타일 XP, 관련 테마, 폰트 등)가 파이어폭스와의 궁합과 맞지 않을 수도 있습니다(이 부분은 제가 윈도우 꾸미기에서 손 땐지 오래라 확인할 수가 없군요. 일단 이 부분은 제외하지요.).

유저 아바타
xeon
서포터즈
서포터즈
게시물: 94
참여됨: 2004 03 05 16:13 00

Background Image

게시물 작성자 xeon » 2005 03 14 14:23 44

사이트는 정상입니다.

어찌된 일인지 Background이미지만 출력되지 않고 있네요...
Background이미지를 제외한 나머지 부분은 정상인걸로 봐서는 CSS를 인식 못하는것 같지도 않고, 뭐가 문제인지.......
일단 관련 옵션은 FF에 없는것 같습니다. 있다면 about:config 부분에서 설정해 주어야 할것 같은데 잘 모르겠네요...

삭제후, 재인스톨 해보세요. 프로필 파일도 함께 삭제 해주셔야 합니다.

kiryu
게시물: 48
참여됨: 2004 11 30 15:51 28
연락:

저는 배경도 잘 보입니다만...

게시물 작성자 kiryu » 2005 03 14 16:43 13

background image도 매우 잘 보입니다.
그런데, 스킨쪽 css에 보니
background: #ffffff url(http://md.egloos.com/skn/img/b/00/01/7/introback.jpg) repeat-x fixed;
로 되어 있는데, 혹시 배경주소에 따옴표로 묶어보시면 어떨까요?

하지만 제 불여우에서는 제대로 보이니 그 문제는 아닌 듯도 하네요.
저는 1.0.1 사용중이고, 확장은 이것저것 깔려있지만, 이미지와 관련된 확장은 깔지 않았습니다.

유저 아바타
xeon
서포터즈
서포터즈
게시물: 94
참여됨: 2004 03 05 16:13 00

Re: 저는 배경도 잘 보입니다만...

게시물 작성자 xeon » 2005 03 14 17:29 13

kiryu 씀:background image도 매우 잘 보입니다.
그런데, 스킨쪽 css에 보니
background: #ffffff url(http://md.egloos.com/skn/img/b/00/01/7/introback.jpg) repeat-x fixed;
로 되어 있는데, 혹시 배경주소에 따옴표로 묶어보시면 어떨까요?

하지만 제 불여우에서는 제대로 보이니 그 문제는 아닌 듯도 하네요.
저는 1.0.1 사용중이고, 확장은 이것저것 깔려있지만, 이미지와 관련된 확장은 깔지 않았습니다.
ㅡ.,ㅡ;;; 그러니까 제얘기도 저나 다른분들은 제대로 보인다는 얘기에요
오직 Mirai님만 Background Image가 출력되지 않는다는 말이구요...

CSS는 이글루 제공이라서 사용자 임의로 수정이 불가능하지 않나요??

아... 저도 엄청 궁금해 지네요 왜 그런건지...... 간단한 문제 일것 같기도 하고... 고수님들이 빨리 답변 남겨주셨으면 좋겠습니다.

소프트원트

게시물 작성자 소프트원트 » 2005 03 14 17:58 00

모질라파이어폭스에서 해당 사이트를 보는 데, 문제가 없내요.

그리고 내용을 보시면 아시겠지만, 문제가 생길 때는 가능한 확인할 수 있는 주소(URL)를 함께 알려주는 게, 시간을 아끼는 것이라는 것을 알 수 있을 것입니다. 모질라 파이어폭스와 관련한 문의를 할 때는 모두들 그렇게 했으면 합니다.

단지 소스를 보면,

코드: 모두 선택

 <style type="text/stylesheet">
가 빠져있내요. 이를 수정해보신 다음에 확인해보시죠..

그리고 사용자가 스타일을 수정할 수 있다면, 링크형 스타일시트를 사용하는 게 좋지않나 싶내요. 관리적 차원에서 수월하니까요.

코드: 모두 선택

<link rel="stylesheet" type="text/css"
href="사용자 스타일시트파일.css" />

소프트원트

앗, 실수...

게시물 작성자 소프트원트 » 2005 03 14 18:01 01

다시 확인해보니, style 시작이 있군요.

이런 미안합니다.

kiryu
게시물: 48
참여됨: 2004 11 30 15:51 28
연락:

Re: 저는 배경도 잘 보입니다만...

게시물 작성자 kiryu » 2005 03 14 19:04 19

xeon 씀:CSS는 이글루 제공이라서 사용자 임의로 수정이 불가능하지 않나요??
이글루는 사용자가 스킨을 편집할 수 있도록 기능을 제공하고 있습니다.
그리고, 지금 Mirai님이 사용하시는 스킨도 회원제작스킨이네요. ^^

명확한 원인을 알 수 있으면 좋겠지만...
아무래도 문제가 있으신 Mirai님이 아니고서야 당장에 알 수야 없겠지요. :-)

유저 아바타
mirai
서포터즈
서포터즈
게시물: 87
참여됨: 2005 03 13 21:45 04
위치: 집안[...]
연락:

해결이 되었네요;

게시물 작성자 mirai » 2005 03 14 19:07 07

어떻게 된건지는 모르겠습니다만;


프로필 폴더를 완전히 삭제했다가 다시 파폭을 실행하니 정상으로 읽혀지더군요;

적어도 시작페이지의 구글 검색 페이지와
이 공식홈페이지는 잘 보입니다.

나머지는 IE에 맞춰져 제작한 탓이라 생각하면서...




도움말 주신 여러분 감사합니다;
그나저나 이유는 뭐였을지;;
도중에 프로필이 잘못된 거였을까요?

박민권
해커
해커
게시물: 724
참여됨: 2005 01 31 22:33 55
위치: 대한민국
연락:

Re: 해결이 되었네요;

게시물 작성자 박민권 » 2005 03 14 21:56 59

mirai 씀:어떻게 된건지는 모르겠습니다만;

프로필 폴더를 완전히 삭제했다가 다시 파폭을 실행하니 정상으로 읽혀지더군요;
문제없이 실행되서 다행입니다. ^^
그나마 불여우니까 지우고 다시깔 수 있지 익스라면 불가능하죠.
윈도우 다시 까는 수밖에.

댓글 게시

누군가 접속

유저들이 이 포럼을 탐색중: 가입된 유저 없음 그리고 11 손님들